Honda Passport Forum banner

21 - 39 of 39 Posts

·
Registered
Joined
·
11 Posts
Discussion Starter #23
Definitely will.

When I first posted about this, it went a long time without any responses. I thought I was alone in having the issue.
I was surprised to see so many responses all at once.
I make sure to bring it up with Honda Canada every chance I get when I get satisfaction surveys and mention the number of people in this forum that share there same issue.
 

·
Registered
Joined
·
3 Posts
Its likely the blower box. Apparently they had some bad ones, and above a certain blower speed, it leaks air at the seams and whistles. I just got my 2019 Elite back from the dealer today after they replaced the center blower box and the noise is gone, so there is a fix. Unfortunately, it does require removal of the entire dashbord, evac and recharge of the A/C system, and disconnecting and reattachment of the heater hoses.

The dealer had already ordered the part for me, so they were ready, and it took them roughly a day and a half to complete the job. Luckily they did a good job and didn’t break or scratch anything, and so far, no rattles.
 

·
Registered
Joined
·
4 Posts
Its likely the blower box. Apparently they had some bad ones, and above a certain blower speed, it leaks air at the seams and whistles. I just got my 2019 Elite back from the dealer today after they replaced the center blower box and the noise is gone, so there is a fix. Unfortunately, it does require removal of the entire dashbord, evac and recharge of the A/C system, and disconnecting and reattachment of the heater hoses.

The dealer had already ordered the part for me, so they were ready, and it took them roughly a day and a half to complete the job. Luckily they did a good job and didn’t break or scratch anything, and so far, no rattles.
Please provide the dealership that serviced this, so other dealerships can reference. My dealership acted like they fixed the problem, but nothing changed. Thank you and glad yours is fixed!
 

·
Registered
Joined
·
4 Posts
I registered just to report on this particular topic. My 2019 goes in on Friday for a heater box replacement. It developed the strange vent whistle after our first real cold snap here in Illinois. Same as everyone else describes, a sucking whistling noise audible at the higher fan speeds. Dealer originally replaced the HVAC fan motor thinking that was the issue, and it was not. After some back and forth, and some time spent at the dealer, they decided (I assume with Honda's blessing), to replace the heater box assembly. As others reported this is a full dash out, AC discharged, heater core disconnected, job. They are planning to keep it for two days.

I'll report back here when the work is done.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #30
I was notified today that the parts have arrived and the heater box will be replaced next week. The dealer will also have my vehicle for two days. I will re-post when the job is complete.
 

·
Registered
Joined
·
3 Posts
I am happy to report that 1000 miles after the replacement of the blower box, my heat and air is still whistle free, so the repair seems to have done the trick. I neglected to get a copy of the repair order, but I do know they replaced the blower box itself, and to do so required complete removal of the dashboard. I hope this helps.
 

·
Registered
Joined
·
11 Posts
Discussion Starter #34
I got my Passport back from the dealer after replacing the heater box today. After a 1.5 hour drive, so far no whistling, it is great!
 

·
Registered
Joined
·
4 Posts
Well, mine isn't fixed yet. It's been at the dealership since last Friday.They did replace the heater box along with another component, but it didn't correct the issue. So they spent a lot of time on with the Honda tech line, and had a webinar with a Honda FE. Finally, yesterday they traced the problem to the seal around where the AC evaporator lines come through the firewall. They were able to change the intensity and tone of the noise by pushing on the seal while the fan was running. It also was loud enough for the remote Honda tech folks to hear via a recorded video. So more parts have been ordered. In the mean time, I'm going to pick the car up today, and then reschedule a time to get that part replaced once it arrives (hopefully sometime next week).

It's also my understanding that this work won't require quite the full dash assembly that the heater box replacement did.
 

·
Registered
Joined
·
4 Posts
Well, my Passport is all fixed. As I stated earlier, the replacement Heater Box assembly didn't correct the issue, and they traced the issue to a leaking seal. Well, I'm pleased to report that when I picked it back up today, it's all fixed, the noise has been eliminated.

Attached is a snip of the invoice showing the parts they replaced. This was no where near as invasive of job as the heater box replacement was. My understanding is that the dash didn't have to come out for this.

It's part number 10 on the attached parts breakdown, plus the two washers (8 and 9).

passport.JPG passport parts.JPG
 

·
Registered
Joined
·
4 Posts
Oh, and for those that may want to know, they replaced both the Heater Assembly (blower box) 79106-TZ5-AZ1 and then the Blower Assembly 79035-TZ5-A42, which did not correct the problem in my case.
 

·
Registered
Joined
·
70 Posts
Well, my Passport is all fixed. As I stated earlier, the replacement Heater Box assembly didn't correct the issue, and they traced the issue to a leaking seal. Well, I'm pleased to report that when I picked it back up today, it's all fixed, the noise has been eliminated.

Attached is a snip of the invoice showing the parts they replaced. This was no where near as invasive of job as the heater box replacement was. My understanding is that the dash didn't have to come out for this.

It's part number 10 on the attached parts breakdown, plus the two washers (8 and 9).

View attachment 4950 View attachment 4951
Thank you for the followup. Now I know what to tell my dealer.
 

·
Registered
Joined
·
4 Posts
The good news - my blower box was finally replaced and the whistle is gone! It took multiple visits to identify the problem and the install was a couple of days.

The bad news - my floor heat has not worked since. When I set the mode to floor - the defrost turns on, so I’m going back in again on Monday. Hopefully this will be the end...
 
21 - 39 of 39 Posts
Top