Honda Passport Forum banner

1 - 3 of 3 Posts

·
Registered
Joined
·
5 Posts
Discussion Starter · #1 ·
I picked my new (only 9km on the odometer) Touring up this morning from the dealership. Looks great in deep scarlet pearl with the fender flares!

I drove ~6-7km home, parked in the driveway leaving the engine running and starting playing with the doodads and adjusting settings.

I noticed a mild burning smell, which I assume (hope) is just extra fluids etc being burning off during the drive and idling, especially since the vehicle hasn't been driven at all previous to me picking it up.

I was however, more concerned about seeing a good bit of (what I think is) steam (because it didn't have a smell that I could detect) coming up from the front of the hood! I opened the hood and located the approximate source to the area in front of the battery. Can't really see into this area because of the plastic shield, so I just left the hood up for another 10-15 min while I fiddled behind the wheel. The steam came and went.

I notice that the engine compartment definitely runs hot (hotter than my older Xterra at least) - wondering if this could be just water from a wash that is boiling off on a hot part, or something else. I would have thought that it would have been dried off by the time I drove home though.

I have to leave town for a couple of days, then my wife takes the Passport for a weekend trip with the kids so I'm a little concerned that there might be an issue.

Any thoughts?
 

·
Registered
Joined
·
35 Posts
I picked my new (only 9km on the odometer) Touring up this morning from the dealership. Looks great in deep scarlet pearl with the fender flares!

I drove ~6-7km home, parked in the driveway leaving the engine running and starting playing with the doodads and adjusting settings.

I noticed a mild burning smell, which I assume (hope) is just extra fluids etc being burning off during the drive and idling, especially since the vehicle hasn't been driven at all previous to me picking it up.

I was however, more concerned about seeing a good bit of (what I think is) steam (because it didn't have a smell that I could detect) coming up from the front of the hood! I opened the hood and located the approximate source to the area in front of the battery. Can't really see into this area because of the plastic shield, so I just left the hood up for another 10-15 min while I fiddled behind the wheel. The steam came and went.

I notice that the engine compartment definitely runs hot (hotter than my older Xterra at least) - wondering if this could be just water from a wash that is boiling off on a hot part, or something else. I would have thought that it would have been dried off by the time I drove home though.

I have to leave town for a couple of days, then my wife takes the Passport for a weekend trip with the kids so I'm a little concerned that there might be an issue.

Any thoughts?
If temperature gage remained normal, I'd return to dealer immediately and make sure they prepped it properly and that nothing is wrong. If temperature gage was abnormal, I'd make them come and get it. It's probably just what you said, spilled fluids evaporating from the manifold or other hot structure; however, with a brand new baby I'd say better safe than sorry.
 

·
Registered
Joined
·
381 Posts
What he said ^^^^^^^
 
1 - 3 of 3 Posts
Top