Honda Passport Forum banner

1 - 13 of 13 Posts

·
Registered
Joined
·
4 Posts
Discussion Starter #1
I'm currently approaching 1800 miles and yesterday I started hearing crackling and popping sound whenever the PP runs to a bump. After a while, I get the Network Communication Lost displayed and the head unit will boot loop or will stay off. I thought it was the windshield at first but confirmed it was the speakers. I hear the crackling and popping sound even when the volume is set to zero.

Could be related to the issue first reported here (can't post links yet. Thread is titled Loss of power to infotainment cluster as well as instrument cluster.). Mine happens only when I run into bumps and I do not lose the front display that shows the tachometer and speedometer. Network Communication Lost is also displayed in the head unit display and then it reboots/stays off.

Anyone had the same issue? I have already scheduled a service. First the AC issue and now this. I have the Passport Touring.
 

·
Super Moderator
Joined
·
973 Posts
I hear the crackling and popping sound even when the volume is set to zero.
Me too, except mine is totally random (it's not related to bumps). I haven't have a chance to bring my car in to be looked at yet -- but I'm gonna have to pretty soon.
 

·
Registered
Joined
·
434 Posts
I'm currently approaching 1800 miles and yesterday I started hearing crackling and popping sound whenever the PP runs to a bump. After a while, I get the Network Communication Lost displayed and the head unit will boot loop or will stay off. I thought it was the windshield at first but confirmed it was the speakers. I hear the crackling and popping sound even when the volume is set to zero.

Could be related to the issue first reported here (can't post links yet. Thread is titled Loss of power to infotainment cluster as well as instrument cluster.). Mine happens only when I run into bumps and I do not lose the front display that shows the tachometer and speedometer. Network Communication Lost is also displayed in the head unit display and then it reboots/stays off.

Anyone had the same issue? I have already scheduled a service. First the AC issue and now this. I have the Passport Touring.
What AC issue did you have?
 

·
Registered
Joined
·
4 Posts
Discussion Starter #4
What AC issue did you have?
Same issue reported here. AC does not blow cold air the same day I got the car. Didn't realized AC does not work since it was fairly cold that day when I got the car. Scheduled a service the next day to a Honda Service Center near me asked me to pay $1k for parts and labor for a 1 day old car to fix the AC. They want to replace the parts #s from Service Bulletin linked above but I haven't seen this yet at that time. Took it to the dealer where I bought the car and they fixed it using the same part #s from the Service Bulletin.
 

·
Registered
Joined
·
434 Posts
Okay I was wondering if that was the case, I posed that TSB but no one had been experiencing the issue yet. Sorry to hear about your troubles. These passports are turning into lemons and it hasn’t even been a year!
 

·
Registered
Joined
·
4 Posts
Discussion Starter #6
Me too, except mine is totally random (it's not related to bumps). I haven't have a chance to bring my car in to be looked at yet -- but I'm gonna have to pretty soon.
You should have it serviced soon. I only had the car for less than a month and I already had 2 major problems - this head unit issue and AC does not blow cold air. I always buy brand new cars to relieve me from these kinds of headaches and it has worked for a long time until I got this Honda.
 

·
Registered
Joined
·
434 Posts
You should have it serviced soon. I only had the car for less than a month and I already had 2 major problems - this head unit issue and AC does not blow cold air. I always buy brand new cars to relieve me from these kinds of headaches and it has worked for a long time until I got this Honda.
Yeah we had to have new front struts at 500 miles as well as an alignment because the steering wheel was off center and it pulled right, not to mention the loose grab handles and trim pieces everyone has! I wouldn’t be surprised if we get out of it by the end of the 3yr/36,000 mile warranty but who knows maybe we won’t have anymore problems? I still worry about transmission failure..
 

·
Registered
Joined
·
4 Posts
Discussion Starter #8
Got the car back. Honda Service Center said they have to literally bring someone from Honda, whatever that means, to diagnose the problem and didn't find the cause. They said they took out and reset the system. They had the car for more than 6 hours.

Seems like whatever they did fixed the problem for now.
 

·
Registered
Joined
·
434 Posts
Got the car back. Honda Service Center said they have to literally bring someone from Honda, whatever that means, to diagnose the problem and didn't find the cause. They said they took out and reset the system. They had the car for more than 6 hours.

Seems like whatever they did fixed the problem for now.
Well hopefully the problem is resolved! It seems like every week someone is experiencing a new issue with these passports.. just makes you wonder what’s next?
 

·
2019 Touring: since March-2019
Joined
·
2,825 Posts
Anyone that is having excessive issues, should buy the extended warranty, if you plan on keeping it for more than 3 years..

I have not had any problems, but am considering buying the extended warranty now that we have all the various issues popping up...
 

·
Registered
Joined
·
2 Posts
I’m having the same issue. I bought the vehicle a month ago and my audio unit will crackle and pop like the others described earlier and the audio unit will completely shut down. Nothing will make it turn on afterwards. The unit begins to boot up and once it does it plays about 30 seconds before it started again. The message says “Network Communication Lost” and that’s it. I haven’t contacted the dealer yet buys it’s been happening about 4 days now.

I thought it was the iPhone plug touching the wireless charging mat but it still does with our without the phone plugged in now.
 

·
Registered
Joined
·
2 Posts
Update. I took my PP to Honda over a week ago. The PP is still there waiting for a harness that will not ship until Jan 22. They said it’s a “known issue” and I should get my car back in about 3 weeks. Honda gave me a Pilot in the meantime to drive and also offered to give a free accessory, but I haven’t picked it out yet.... I just want my car back.
 
1 - 13 of 13 Posts
Top