Honda Passport Forum banner

1 - 10 of 10 Posts

·
Registered
Joined
·
109 Posts
Discussion Starter #1
Anyone getting the hood flutter that has plagued the Ridgeline/Pilot where the top of hood has separated from the under skin? Curious if they have fixed this with the Passport.
 

·
Registered
Joined
·
109 Posts
Discussion Starter #3
I have a 2019 Ridgeline that had this. Was fluttering at highway speeds and when passing semi's. The dealer solution was to glue it back together. It actually worked and haven't had any issues since. If you remove one of the pins that hold the felt liner in place under the hood you can see if yours has separated.
 

·
Registered
Joined
·
109 Posts
Discussion Starter #4
I have a 2019 Ridgeline that had this. Was fluttering at highway speeds and when passing semi's. The dealer solution was to glue it back together. It actually worked and haven't had any issues since. If you remove one of the pins that hold the felt liner in place under the hood you can see if yours has separated.
 

·
Registered
Joined
·
434 Posts
Yeah I see the TSB for the pilot and Ridgeline regarding the issue, but no complaints on the passport forum that I’ve seen yet.
24577F0F-CE87-4B34-B38E-A9105AA678C3.png
 

·
Registered
Joined
·
109 Posts
Discussion Starter #6
Thanks for posting the TSB. I took a copy in when I had the service done. Glad no one has mentioned it on the Passports. It would be the first thing I would look at. Thanks for your comments.
 

·
Registered
Joined
·
434 Posts
Thanks for posting the TSB. I took a copy in when I had the service done. Glad no one has mentioned it on the Passports. It would be the first thing I would look at. Thanks for your comments.
No problem, thanks for inquiring. It’s nice to know of problems like these with other models that way we can monitor our passports for such issues.
 

·
Registered
Joined
·
434 Posts
I’m an automotive technician so I have access to a repair database called AllData that lists manufacturer’s repair procedures as well as TSBs and recalls.
 

·
Registered
Joined
·
569 Posts
I had a similar problem with my 2009 Accord after front-end collision repaired. The body shop installed but inverted the rubber cushion/seal on the leading edge of the hood. It left a gap between the hood and bumper. Figured it out and fixed the issue myself.
 
1 - 10 of 10 Posts
Top