Honda Passport Forum banner

61 - 80 of 117 Posts

·
Registered
Joined
·
19 Posts
I believe they would due to the factory bulbs being the same.
Ok, thought so but saw a posting saying to use the 7443 instead. I prefer the 7440’s posted since it has the resistor for hyperflashing already in it...

Thanks!!!
 

·
Registered
Joined
·
67 Posts
Ok, thought so but saw a posting saying to use the 7443 instead. I prefer the 7440’s posted since it has the resistor for hyperflashing already in it...

Thanks!!!
I went with the 7443 due to that being used on the Pilot when searching Lasfit website they also have the resistor on the updated 2019 style.
 

·
Moderator
Joined
·
627 Posts
My .02 is that they may be too long but I’m not sure at all as I have the shorter ones coming and Clemson may know more as he has actually done the fronts...
 

·
Moderator
Joined
·
627 Posts
I did the Lasfit 7440 (rear signals) and Lasfit 7443 (front signals) and so far no issues at all (no hyperflash or going out of sync after 15 minutes). I’m in to these about a week and will report back if any issues pop up and I do like having all LED now 😎
 

·
Registered
Joined
·
246 Posts
I did the Lasfit 7440 (rear signals) and Lasfit 7443 (front signals) and so far no issues at all (no hyperflash or going out of sync after 15 minutes). I’m in to these about a week and will report back if any issues pop up and I do like having all LED now 😎
I really appreciate the help! (y)
 

·
Registered
Joined
·
246 Posts
Just an observation but, aren’t these a bit pricey?
 

·
Registered
Joined
·
5 Posts
Going to keep an eye on this thread. This is one of the first "upgrades" i'd like to do, but Id like to see if more options appear and if the pricing levels out a bit. I'd probably look at doing the front turn/rear turn and the reverse lights first.
 

·
Registered
Joined
·
246 Posts
I was kind of surprised that the new Passport wasn't introduced with LED turn signals considering the less expensive CR-V and Civic both have them now.
 

·
Registered
Joined
·
5 Posts
I did the Lasfit 7440 (rear signals) and Lasfit 7443 (front signals) and so far no issues at all (no hyperflash or going out of sync after 15 minutes). I’m in to these about a week and will report back if any issues pop up and I do like having all LED now 😎
any tips on how to replace the front signal bulbs? was it easy to replace, any videos?

Thank you.
 
61 - 80 of 117 Posts
Top