Honda Passport Forum banner

401 - 420 of 892 Posts

·
Premium Member
2020 Passport Elite - Modern Steel Metallic w/Black Leather
Joined
·
825 Posts
Thank god I found this forum. Thought I was going nuts. Radio stations and Sirius skip like an old record . Each time I head to the dealer, by the time I get there I can’t duplicate it. Car had 1100 miles on it . I have been hitting the top of the dash each time it happens and that stops it till the next time. How can there not be a fix for this??
Which year and model/trim level?
 

·
Registered
Joined
·
14 Posts
My wife's 2019 PP EX-L AWD has been having problems the past couple weeks with the Apple CarPlay not working. Last night, I plugged in a USB keyboard, did the CTRL-ALT-DEL, and re-added her iPhone 8+ to bluetooth first and then CarPlay. I then also added my iPhone 11 Pro to CarPlay. I even replaced the genuine Apple USB cable with a new one just to be sure. I drove it a bit last night and no issues. She drove this morning with no issues.

But this afternoon when she drove she said she had the issue again. WTF? I was thinking of buying another PP for myself and passing my CR-V to the kids, but this is really irritating!
 

·
Registered
Joined
·
34 Posts
I have the same problems with my radio screen going off over and over again, also the odometer screen goes black at times as well. The first time I brought it to the dealership they said it was a loose amplifier cable. Received car back and that did not fix the problem. The second time they replaced the wiring harness and when I drove out of the parking lot it was skipping and going off and on yet again. I will be contacting them on Monday. This is totally unacceptable.
 

·
Super Moderator
Joined
·
2,309 Posts
I have the same problems with my radio screen going off over and over again, also the odometer screen goes black at times as well. The first time I brought it to the dealership they said it was a loose amplifier cable. Received car back and that did not fix the problem. The second time they replaced the wiring harness and when I drove out of the parking lot it was skipping and going off and on yet again. I will be contacting them on Monday. This is totally unacceptable.

Hello Stacy and welcome to the Forum, so sorry your first post here has to be under these circumstances, it seems like the Dealers are clueless on a lot of the Passport problems and it does not appear that Honda Corp is aware of them either! It's probably just one little thing (that is defective), however finding it is often like the proverbial "needle in a haystack"..

Stick with pushing the dealer to handle it and once fixed you will be able to fully enjoy your vehicle like many other Passport owners here...

Cheers!
 

·
Registered
Joined
·
129 Posts
My harnace was replaced. Dealer kept my vehicle for two weeks. Hopefully, this solves the issue.
Yikes two weeks!!?!?!?!?!

What disturbs me most about any of these wiring issues is that no doubt the dash has to be completely torn-apart. They never go back-together again perfectly!!!

:oops:
 

·
Registered
Joined
·
3 Posts
My car is the Passport AWD Touring. So I was driving to a golf course and I had my iPhone plugged in. The apps that were running were the Apple Music app and Waze. All of a sudden i heard a pop and buzz sound over the speakers and from that point on no sound would play whatsoever. The music app would not work, the SiriusXM would not work and would display “tuner not found”. The fm/am would not play. No sound from any source would play. The unit display would work perfectly fine and was fully operational however, but would not shut off. So when I turned the car off and opened the drivers door the display was still on. I was very concerned about this running down my battery.
I had to take the car back to the dealer. They had to disconnect the battery to shut the display off. The dealer said they think that the non apple iPhone cord might have been the problem. So I went and bought a apple branded lighting cord and it worked good the rest of today.
This morning I struck out again, pulled up Waze and Apple Music and the same thing happened again. I took it back to the dealer and now they are saying they think a bug in Waze app is causing the issue. So starting now I won’t be using Waze. I hope it is the Waze app causing this issue.
 

·
Registered
Joined
·
3 Posts
Update: I returned the pp to the dealership on January 23rd, the 4th time for the same issue, 23 hours after they gave it back to me. I have 9 different videos of the issue in that 23 hour time period. The issue is getting worst, it's happening more frequently, for longer time and I am loosing functions on the touch screen and the steering wheel. The dealership has had my pp for 38 days now. They called me yesterday and said they think its the amplifier. The part will be in next week and then they want to keep it a while longer for testing after they replace the part. I'll keep you posted.
it’s likely the wire harness. Had mine replaced and sounds have finally stopped
 

·
Super Moderator
Joined
·
959 Posts
it’s likely the wire harness. Had mine replaced and sounds have finally stopped
Do you have a Service Bulletin or any other documentation you can share? I spoke with Honda America (corporate) today and they claim to not be aware of the problem. I need something that I can bring to my dealer to show them what the issue is -- otherwise they won't do anything since they can't reproduce the problem.
 

·
Registered
Joined
·
1 Posts
SAME! The loud beep; the tech I talked to suggested there may be a short in one of the wiring in the speakers and that requires taking the head unit out of the dash and testing each connection in the back of the head unit; lucky for me it never got to that point. So after three occurrences and two visits to the dealer (and they can’t say it has a problem unless it is stuck in that state of no audio with the screen stuck on), they did a Master Reset (not sure what that involves) and a software update. This was back in November and so far so good. Yes, you can pull the fuse for the infotainment system in the engine bay to get the screen to turn off but it’s not a permanent fix. I didn’t use Waze nor had it installed as one of the NAV app; straight Apple Car Play.

As inconvenient as it is, when this happens take it straight to the dealer and show them! They will not admit there is a problem with the infotainment system unless they see it, despite the numerous posting on a forum.
Same thing happened to me I also have frequent issues with Bluetooth and audio using the phone. Frequent issues with not being able to turn the volume up and down, locking up panel. Anyone have any success getting Honda to do anything? Mine is in the shop right now and I’m told it works...and I couldn’t use it when I dropped it off. Aggrevating.
 

·
Registered
Joined
·
11 Posts
I have the same problems with my radio screen going off over and over again, also the odometer screen goes black at times as well. The first time I brought it to the dealership they said it was a loose amplifier cable. Received car back and that did not fix the problem. The second time they replaced the wiring harness and when I drove out of the parking lot it was skipping and going off and on yet again. I will be contacting them on Monday. This is totally unacceptable.
The Harnace was replaced on my vehicle and it seems to be working now!
 

·
Read Only
Joined
·
395 Posts
Just going to offer this idea. My previous vehicle, 2013 Pilot Touring developed a problem with the screen of the Nav/Entertainment System were the screen would go black with crazy white lines across it. Usually stopping the car, shutting it off and restarting it would clear the problem up, for a while. Documented it with photos and the dealer agreed that there was something wrong. Reached out to Honda did everything they suggested and still had the problem. The dealer reached out for a replacement and was turned down since the dealer could not replicate the issue.

Being a tech guy I asked the dealer to blow out the software completely and reinstall it. They were hesitant as Honda had not suggested doing so, but they agreed to try it. Took a couple of hours to do a clean install of the software but they did it. Never had the issue again.
 

·
Premium Member
2020 Passport Elite - Modern Steel Metallic w/Black Leather
Joined
·
825 Posts
it’s likely the wire harness. Had mine replaced and sounds have finally stopped
I’d like to make a recommendation. It would be helpful if all members could put the year and trim level in their signature so that we know what year/trim level is having the issue. This should come in very handy for all. Maybe we can make this a sticky.
 

·
Registered
Joined
·
129 Posts
...Being a tech guy I asked the dealer to blow out the software completely and reinstall it. They were hesitant as Honda had not suggested doing so, but they agreed to try it. Took a couple of hours to do a clean install of the software but they did it. Never had the issue again.
And how does one do that, exactly?
 
401 - 420 of 892 Posts
Top